Matchmaking issues in Fall Guys

Incident Report for Epic Games Public

Resolved

Matchmaking issues in Fall Guys have been resolved.
Posted Dec 11, 2025 - 20:38 UTC

Investigating

We are aware of the matchmaking issues some players might be experiencing when trying to access different shows.
We are investigating and will share more information once it becomes available.
Posted Dec 11, 2025 - 17:29 UTC
This incident affected: Fall Guys (Matchmaking).