Purchases and free game redemptions on the Epic Games Store, as well as V-Bucks and other money transactions in Fortnite, have been restored and are no longer showing an error message. Thanks everyone for your understanding, and we'll continue monitoring this to ensure servers remain stable.
Posted Dec 12, 2025 - 06:01 UTC
Update
While we continue to investigate and resolve this issue, V-Bucks and other money transactions are also affected and may fail to load when trying to purchase.
Posted Dec 12, 2025 - 04:01 UTC
Update
We are continuing to investigate this issue.
Posted Dec 12, 2025 - 03:59 UTC
Investigating
We’re working to resolve the Epic Games Store erroring when trying to redeem or make a purchase, and appearing in a different language than what you selected.
Posted Dec 12, 2025 - 03:15 UTC
This incident affected: Epic Games Store (Purchasing/Refunding, Store Browsing) and Fortnite (Item Shop).