LEGO Fortnite Odyssey - Matchmaking Issues in Europe

Incident Report for Epic Games Public

Resolved

Matchmaking services have been restored. Thank you for your patience while we resolved the issue.
Posted Jul 26, 2025 - 20:51 UTC

Investigating

Some players in the Europe region may be seeing matchmaking errors when accessing their Worlds in LEGO Fortnite Odyssey.

We're working to restore matchmaking stability and will provide an update as soon as the issue is resolved, or when more information is available.
Posted Jul 26, 2025 - 17:08 UTC
This incident affected: LEGO Fortnite (Matchmaking).